Email Connection Issues
Resolved
Microsoft has confirmed that the issue is resolved.
Posted Jun 21, 2022 - 19:55 EDT
Monitoring
A fix has been implemented, and the vendor is monitoring for stability.

Next update when Microsoft releases new information.
Posted Jun 21, 2022 - 15:25 EDT
Investigating
Microsoft has alerted us to a partial outage with their email platform. Users may not be able to connect to their mailboxes through the Outlook client, MyApps email link, or on a smart phone mail client.

The vendor is currently working on a fix for this issue. Next update within 2 hours.
Posted Jun 21, 2022 - 13:06 EDT
This incident affected: Managed IT Services (Email / Office 365).