WebCRD

Resolved

WebCRD is up and working.
Posted Nov 05, 2025 - 10:10 EST

Investigating

WebCRD is currently down. We have reached out to the vendor, and they are working to resolve the issue
Posted Nov 05, 2025 - 07:38 EST
This incident affected: BTBOCES Duplicating Center (WebCRD).