MyApps Portal Error 400 Bad Request
Resolved
The vendor has deployed a fix, and access to the MyApps portal has been restored. We apologize for the interruption.
Posted Apr 01, 2021 - 18:07 EDT
Update
We are continuing to work with the vendor to resolve the issue. Next update when we have more information to share from the vendor.
Posted Apr 01, 2021 - 17:30 EDT
Update
Update: Many MyApps-enabled apps may still work if users go directly to the app instead of starting from the MyApps portal. Example: going directly to classroom.google.com will allow the users to authenticate.

Next update within 1 hour.
Posted Apr 01, 2021 - 15:56 EDT
Investigating
We are seeing issues with the MyApps portal that prevent users from reaching the portal page. The users see an error 400 "Bad Request."

The issue appears to be on the vendor side of things. We are engaging the vendor right now an will update within the hour with new information as we receive it.
Posted Apr 01, 2021 - 15:53 EDT
This incident affected: Managed IT Services (MyApps Portal).