Frontline Login Issues
Resolved
The vendor has indicated that the issues on the Frontline platform have been resolved. Users should now be able to access Frontline IEP and Frontline Education Professional Growth.
Posted May 03, 2021 - 11:27 EDT
Investigating
We have received reports from users that the Frontline platform is experiencing issues. Many users are currently unable to access Frontline IEP and Frontline Education Professional Growth.

The vendor is aware of the issue and is working to deploy a fix to restore access. We will update this status notification as soon as we receive more information from the vendor.
Posted May 03, 2021 - 09:12 EDT
This incident affected: Special Education Systems (Frontline IEP) and Frontline Education Professional Growth.