Google G Suite Issues
Resolved
Google has resolved the issues with Google Drive and the other affected services. Thank you for your patience while the services were down.
Posted Apr 12, 2021 - 12:57 EDT
Monitoring
Google has deployed a fix and is currently monitoring the situation. From Google:

"Google Drive service has already been restored for some users, and we expect a resolution for all users within the next 35 minutes. Please note this time frame is an estimate and may change. The affected users are able to access Google Drive, but are seeing error messages, high latency, and/or other unexpected behavior.

Please try reloading the page, or coming back to it in a few minutes."

We will update this status notification when we receive confirmation from Google that the issue is resolved.
Posted Apr 12, 2021 - 12:29 EDT
Update
From the vendor:

"Our team is continuing to investigate this issue. We will provide an update by 4/12/21, 12:00 PM with more information about this problem. Thank you for your patience. The affected users are able to access Google Drive, but are seeing error messages, high latency, and/or other unexpected behavior."

We will update again when we hear more from Google.
Posted Apr 12, 2021 - 11:12 EDT
Investigating
We have been informed that Google is experiencing issues with their platform that affects Google Drive, Docs, and some Classroom functionality.

At this time, the vendor is working to identify and fix the issue. See Google's status page for more information:

https://www.google.com/appsstatus#hl=en&v=status

We will update this notification when we hear more information from Google.
Posted Apr 12, 2021 - 10:10 EDT
This incident affected: Managed IT Services (Google Accounts).