Frontline Login Issues
Resolved
The vendor has deployed a fix, and we are hearing that customers can now login to the Frontline platform,
Posted May 10, 2021 - 09:25 EDT
Investigating
We are receiving reports this morning of users unable to login to Frontline IEP and Frontline Professional Growth through the MyApps portal.

We're currently investigating this issue and have contacted the vendor for assistance. We'll post an update within the next 2 hours.
Posted May 10, 2021 - 08:10 EDT
This incident affected: Special Education Systems (Frontline IEP) and Frontline Education Professional Growth.