Regional Internet Connection Outage
Resolved
We have deployed a fix, and Internet access has been restored.
Posted Sep 15, 2020 - 13:59 EDT
Investigating
We are currently experiencing an issue with the Regional Internet connect that is impacting most traffic coming to and from our network. All Internet connected applications are impacted. Our network team is investigating a fix. Next update within 30 minutes.
Posted Sep 15, 2020 - 13:41 EDT
This incident affected: Regional Internet Connection.