Portal.scric.org Remote Desktop and WinCap Issues
Resolved
The issues with portal.scric.org have been resolved.
Posted Apr 13, 2021 - 11:25 EDT
Monitoring
Our Engineering team has deployed a fix and we're monitoring for stability. Next update within 1 hour.
Posted Apr 13, 2021 - 09:24 EDT
Investigating
We are currently investigating reports of issues using the Portal.scric.org site to connect to remote desktops and to applications like WinCap. Our Engineering Team is working on a fix. Next update within 1 hour.
Posted Apr 13, 2021 - 08:12 EDT
This incident affected: Financial Systems (WinCap).