Hosted PowerSchool - Degraded Performance
Resolved
The PowerSchool vendor has indicated that the performance issues have been resolved.
Posted Dec 07, 2021 - 07:46 EST
Identified
The vendor has identified the root cause of the issue and is actively working on a fix. Customers in our region will continue to see degraded performance until the vendor deploys a permanent fix.

We will update this status notification when we receive additional information from the vendor.
Posted Dec 03, 2021 - 10:23 EST
Update
The PowerSchool vendor has indicated that performance continues to be degraded while they are working on a fix. We appreciate your patience as they work to solve the issue.

Next update when we receive additional information from the vendor.
Posted Dec 02, 2021 - 10:37 EST
Monitoring
The PowerSchool vendor has indicated that multiple customers are reporting improved performance. We will update this status notification when we receive additional information.
Posted Dec 01, 2021 - 07:23 EST
Investigating
We have received reports over the last day of degraded performance on hosted PowerSchool instances. The vendor is currently still in the process of investigating the root cause of these performance issues.

We will update this status notification as soon as we receive more information from the vendor.
Posted Nov 30, 2021 - 09:28 EST
This incident affected: Student Management Systems (PowerSchool).