Regional Internet Issues

Monitoring

We believe we have found the root cause of the issue and are continuing to monitor. We will provide more updates as they become available. Thanks
Posted Feb 12, 2026 - 12:06 EST

Investigating

We are aware of slow internet throughout the region. We are currently investigating the issue.
Posted Feb 12, 2026 - 08:33 EST
This incident affects: Regional Internet Connection.