nVision & Timepiece Connection Issues

Resolved

Problem has been identified and resolved. Application is available
Posted Mar 12, 2026 - 08:51 EDT

Investigating

Districts are receiving an error when trying to launch nVision & Timepiece, Our team is aware and currently investigating the error.
Posted Mar 12, 2026 - 07:29 EDT
This incident affected: Financial Systems (nVision).