BTBOCES Duplicating Center Online Ordering Issue

Resolved

We have confirmed that the issue is resolved.
Posted Aug 20, 2025 - 16:07 EDT

Monitoring

The vendor has deployed a fix, and users should have access to the WebCRD application now. We will continue to monitor for stability. Next update by end of day.
Posted Aug 20, 2025 - 08:30 EDT

Investigating

For BTBOCES Duplicating Center customers, we are currently experiencing an outage on the online ordering system:

https://documentservices.btboces.org/

We are working with the vendor to diagnose and troubleshoot the issue. We will have a status update sometime tomorrow morning.
Posted Aug 19, 2025 - 16:19 EDT
This incident affected: BTBOCES Duplicating Center (WebCRD).