Regional Internet Degraded Performance
Resolved
This has been resolved
Posted Jun 01, 2023 - 13:27 EDT
Update
We are continuing to monitor for any new issues. Next update by end of day.
Posted May 31, 2023 - 12:04 EDT
Monitoring
The issue has been identified and our technical team has deployed a configuration change to help mitigate the issue. We are currently monitoring for stability.

Next update within 2 hours.
Posted May 31, 2023 - 09:56 EDT
Investigating
We have received reports of degraded performance on the Regional Internet service. Some users have reported experiencing intermittent slowness and timeouts connecting to websites.

Our technical team is currently investigating the root cause of the issue.

Next update within 2 hours.
Posted May 31, 2023 - 09:17 EDT
This incident affected: Regional Internet Connection.