Outlook Mail Issues
Resolved
This has been resolved by Microsoft.
Posted Oct 11, 2024 - 13:30 EDT
Monitoring
Microsoft has made a configuration update that has successfully resolved the Outlook issue. They indicate if you are still experiencing issues, please reboot your computer. If a reboot doesn't solve the issue, please create a Service Now ticket
Next update by tomorrow morning.
Posted Oct 10, 2024 - 14:23 EDT
Investigating
We are aware of issues with Outlook mail where users are experiencing login issues and crashing/freezing issues. Microsoft is aware of its issue and is working on it. We will give an update by the end of the day.
Posted Oct 10, 2024 - 14:02 EDT
This incident affected: Managed IT Services (Email / Office 365).