BoardDocs Login issue

Resolved

This issue has been resolved.
Posted Apr 28, 2026 - 15:52 EDT

Identified

The vendor has confirmed an outage and is actively working to resolve it
Posted Apr 28, 2026 - 12:20 EDT

Investigating

There is a known BoardDocs Login Issue, and the vendor has been notified. As soon as we have more information, we will send out an update.
Posted Apr 28, 2026 - 11:54 EDT
This incident affected: BoardDocs.