Microsoft Email/Office 365 Outage

Resolved

Microsoft deployed a series of fixes last night to resolve the issues. Email delivery and access to Office 365 services such as OneDrive have been restored.
Posted Jan 23, 2026 - 06:37 EST

Investigating

We are currently investigating issues with office 365 including email, teams, and OneDrive that the vendor, Microsoft, has reported. This issue prevents users from sending and receiving email through Exchange Online, which is provided by our Managed IT Service. Additionally, users may experience issues accessing One Drive, and other Cloud Hosted Microsoft Applications.

Microsoft is currently working on deploying a fix. We will provide more information when we receive it from the vendor.
Posted Jan 22, 2026 - 18:35 EST
This incident affected: Managed IT Services (Email / Office 365).