nVision Login Issues
Resolved
The issues preventing login have been resolved.
Posted Dec 01, 2021 - 15:41 EST
Investigating
We are currently investigating reports of an issue that prevents users from logging into the nVision system. We have contacted the vendor and will update this notification within the next 2 hours.
Posted Dec 01, 2021 - 13:37 EST
This incident affected: Financial Systems (nVision).