MITS Districts Office 365 Account Access Outage
Resolved
This has been resolved
Posted Nov 19, 2024 - 10:29 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2024 - 08:42 EST
Identified
We have identified an issue where users have lost access to email, teams, Office 365 Online, and SharePoint Online. We have taken corrective action, and accounts have already started to reconnect. We expect that these services will be fully restored within a couple of hours.

The next update will be tomorrow morning.
Posted Nov 13, 2024 - 15:25 EST
This incident affected: Managed IT Services (Email / Office 365).