Unable to Make Outgoing Phone Calls from School Districts
Monitoring
Verizon has found and repaired the issue overnight. We are getting reports from around the region stating the issue has been resolved and outgoing/long-distance calls are working.
Posted Nov 20, 2024 - 09:18 EST
Update
Verizon is continuing to work on the issue.
Next update tomorrow morning.
Posted Nov 19, 2024 - 16:06 EST
Investigating
There is a known issue when users are unable to make outgoing/long-distance calls from school districts. Verizon is working to rectify this issue.
Next update by 4 PM
Posted Nov 19, 2024 - 10:29 EST
This incident affects: Regional Internet Connection.