Office 365 Mail - Service Unavailable
Resolved
Microsoft are reporting that a series of fixes deployed late yesterday have resolved the lingering issues with Outlook.
Posted Jun 07, 2023 - 07:53 EDT
Monitoring
Microsoft have deployed another fix which seems to mitigate this issue for a majotiy of affected users. We will continue to monitor for stability.

Next update within 2 hours.
Posted Jun 06, 2023 - 07:41 EDT
Identified
We have received some isolated reports of users that continue to be impacted by the issue. Microsoft are aware and are continuing to work on the permanent fix.

Next update tomorrow morning.
Posted Jun 05, 2023 - 16:13 EDT
Monitoring
Microsoft has identified the issue and deployed a fix. We will be monitoring this issue for stability.

Next update by end of day.
Posted Jun 05, 2023 - 13:06 EDT
Investigating
Users are experiencing issues connecting to the Office 365 Mail link in the MyApps Portal. The error message started "503 Service Unavailable."

We are currently investigating the root cause. In the meantime, the Outlook Desktop app continues to work to send/receive emails.

Next update within 2 hours.
Posted Jun 05, 2023 - 10:48 EDT
This incident affected: Managed IT Services (Email / Office 365).