Issues Accessing or Receiving Email
Resolved
The remaining issues with the student email accounts were resolved overnight.
Posted Sep 23, 2021 - 08:14 EDT
Monitoring
We have confirmed that access to email has been restored for all districts staff accounts. Some student email accounts may still be impacted, but this should be resolved later tonight.

Next update tomorrow morning.
Posted Sep 22, 2021 - 16:28 EDT
Identified
The root cause of the issue has been identified and a fix is being prepared. ETA for the service being fully restored is approximately 2 hours.

Next update within 2 hours.
Posted Sep 22, 2021 - 14:13 EDT
Update
Update: The issue appears to be sporadic, some users that are initially not able to access their inboxes are able to after waiting and trying again a few minutes later.

Our Engineers have determined that the root cause is likely on vendor's end (Microsoft Office 365.) We have opened a case with their support team, and are escalating as quickly as we can.

Next update within 1 hour.
Posted Sep 22, 2021 - 14:00 EDT
Investigating
We are currently investigating an issue that prevents users from access or receiving email. Our Engineering Team is working on the issue. Next update within 1 hour.
Posted Sep 22, 2021 - 13:40 EDT
This incident affected: Managed IT Services (Email / Office 365).