MOSAIC and MySchoolBucks

Resolved

The issue has been resolved and users should be able to log in now.
Posted Mar 06, 2026 - 11:13 EST

Investigating

Reports of Mosaic not loading and login problems with MySchoolBucks. The vendor is aware of this and is investigating.
Posted Mar 06, 2026 - 07:52 EST
This incident affected: Cafeteria Management Services (Mosaic).