MITS Districts - Unable to send to Mail Groups

Resolved

This incident has been resolved.
Posted May 09, 2025 - 09:24 EDT

Monitoring

We believe that this issue has been resolved based on monitoring the groups reported and testing with individuals from multiple districts. Microsoft had reported issues across many of the 365 platforms and has resolved those issues, which seemed to be the root of this issue. We will continue to monitor this issue
Posted May 07, 2025 - 09:56 EDT

Investigating

Customers are having issues sending emails to distribution groups that are restricted to specific senders. When emailing these distribution groups, the sender will receive a bounce back email stating that they do not have access to send to this list. We have a ticket open with Microsoft and are currently investigating.
Posted May 06, 2025 - 10:02 EDT
This incident affected: Managed IT Services (Email / Office 365).