eTrition - Log in Issues

Resolved

This issue has been resolved.
Posted May 18, 2026 - 10:53 EDT

Investigating

We are getting reports of there being issues logging into eTrition. We have reached out to the vendor to investigate.
Posted May 18, 2026 - 08:51 EDT
This incident affected: Cafeteria Management Services (eTrition).