MITS Districts Blocked Websites
Resolved
This has been resolved
Posted Nov 07, 2024 - 08:30 EST
Monitoring
The fix is working; we are continuing to monitor.
Posted Nov 06, 2024 - 15:43 EST
Identified
We are aware that MITS districts are encountering various blocked websites. This is due to websites not being classified in the correct Geographical location. We are implementing a workaround which will be completed shortly.
Next update by the end of the day.
Posted Nov 06, 2024 - 12:21 EST
This incident affected: Regional Internet Connection.